All ebuilds that could satisfy „dev-java/sun-jdk“ have been masked: dlj-1.1 license(s)

Vor einigen Tagen ist mir beim Update der Java-Version meines Servers der folgende Fehler untergekommen:

!!! The following installed packages are masked:
- dev-java/sun-jdk-1.6.0.17 (masked by: dlj-1.1 license(s))
A copy of the 'dlj-1.1' license is located at '/usr/portage/licenses/dlj-1.1'.

- dev-java/sun-jdk-1.5.0.22 (masked by: dlj-1.1 license(s))
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

!!! All ebuilds that could satisfy "dev-java/sun-jdk" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-java/sun-jdk-1.6.0.18-r1 (masked by: dlj-1.1 license(s), ~x86 keyword)
A copy of the 'dlj-1.1' license is located at '/usr/portage/licenses/dlj-1.1'.

- dev-java/sun-jdk-1.6.0.18 (masked by: dlj-1.1 license(s), ~x86 keyword)
- dev-java/sun-jdk-1.6.0.17 (masked by: dlj-1.1 license(s))
- dev-java/sun-jdk-1.5.0.22 (masked by: dlj-1.1 license(s))

Die Lösung war das akzeptieren der Lizenz, wie bereits schon in der Meldung gesagt. Jedoch gibt es da verschiedene Möglichkeiten:

  1. Systemweites akzeptieren aller Lizenzen:
    Füge in der Datei /etc/make.conf die folgende Zeile hinzu:
    ACCEPT-LICENSE="*"
  2. Systemweites akzeptieren einer oder mehrer spezifischer Lizenzen:
    Füge in der Datei /etc/make.conf die folgende Zeile hinzu:
    ACCEPT_LICENSE="dlj-1.1
  3. Akzeptieren einer Lizenz für ein Paket:
    Füge in der Datei /etc/portage/package.license die folgende Zeile hinzu:
    dev-java/sun-jdk dlj-1.1

Ich habe mich für letzteres entschieden:

echo "dev-java/sun-jdk dlj-1.1" >> /etc/portage/package.license

Und schon war das Problem gelöst 🙂