German: Dieser Artikel ist auf Englisch, da er an ein internationales Publikum gerichtet ist. In one of the latest posts on the Zend Framework maillinglist there was a question regarding the minimum required version of PHP for the current version Zend Framework (1.9.0). As of Version 1.7.0 of ZF the documentation recommends versions >=5.2.4 for PHP. Some users are stuck with php5.1.6 (e.g. those running Redhat Linux) and these need to know the components that could be problematic.

To see the minimum required version of PHP for each package of ZF, i’ve created a shellscript which uses PHP_CompatInfo from Pear. It doesn’t take the dependencies into account!

For your convinience i’ve created a website with these infos:

http://zfcompat.wolf-u.li/

By the way for all users of Redhat with PHP 5.1.6: In Zend 1.9.0 the following files that need a higher version than 5.1.6. Be aware, that some components are dependend on these files, e.g. Zend_Cache_Backend is used in about 40% of all components (see comment by Thomas below).

ZendCacheBackend.php : 5.2.1 ZendCryptDiffieHellman.php : 5.2.0 ZendCryptRsaKeyPrivate.php : 5.2.0 ZendCryptRsaKeyPublic.php : 5.2.0 ZendCryptRsa.php : 5.2.0 ZendFileTransferAdapterAbstract.php : 5.2.1 ZendNavigationPage.php : 5.2.0 ZendOpenId.php : 5.2.0 ZendPdfPage.php : 5.2.0 ZendPdf.php : 5.2.0 ZendTestPHPUnitDbOperationTruncate.php : 5.2.1

Thanks to Stefan Sturm for this list!

Still, you should run your own tests and check if your application is really working. The Website above just shows the possiblity to run a specific component under a specific php-version and isn’t taking dependencies between components into account. Or simply update to the current version of PHP :P