Conceptronic CH3SNAS

Ich habe mir vorletzten Monat ein neues Gadget geleistet. Unter meinem Schreibtisch(in WM) bzw unter meiner Couch(in MA) steht nun ein kleines NAS (Network Attached Storage) von Conceptronic. Das CH3SNAS ist mit einem Marvell XScale (früher Intel XScale) Prozessor mit 500Mhz, 64MB Ram, 2 S-ATA-Festplatten und (sehr wichtig!) einem Gigabit-LAN-Anschluss ausgerüstet. Da es baugleich mit dem DNS323 von D-Link ist, konnte ich nach einer kurzen Google-Suche bereits herausfinden, dass es eine Möglichkeit gibt,z.B. PHP-Bildergallerien mittels eines nachgeladenen Webservers zu installieren oder einen SSH-Server zu starten. Derzeit betreibe ich das NAS mit einer zwei 500GB Festplatten von Seagate.

Ein paar Eigenschaften noch in der Übersicht:

  • Festplattenkonfigurationen: Standard, JBOD, RAID 0 und RAID 1
  • Programmiertes FTP/HTTP(S)-Download/Backup
  • UPnP AV Server
  • USB Printer Server
  • NTP Server für Systemzeitsynchronisierung
  • iTunes Server
  • DHCP-Server
  • 2 Modi: Offener Modus und Account-Modus
  • Zuweisung von Nutzern / Nutzergruppen
  • Festplatten-Power Management
  • Automatische Ventilator-Stufenregelung mit Wärmesensor
  • Automatische E-Mail-Benachrichtigung

Werbung


Zunächst ein paar Bilder vom NAS:

Nach dem Auspacken und dem Aufbau sollte nun die beigelegte CD eingelegt und ein kurzer Blick in die Bedienungsanleitung geworfen werden, diese ist eigentlich recht übersichtlich und gut verfasst. Sobald das Einschalten des NAS beendet ist, startet man das beigelegte „Suchtool“ und versucht zunächst das NAS im Netzwerk zu finden, um es zu konfigurieren. Wenn man nun die IP entweder weiß (DHCP) oder festgelegt hat (Statische IP), kann man sich auf dem Webinterface einloggen.

Das Webinterface des CH3SNAS präsentiert sich einfach und übersichtlich in verschiedenen „Tabs“. Nach einer Initialisierung meiner 500GB-Festplatte mit dem Dateisystem ext2 konnte ich beginnen, Private Verzeichnisse und Zugriffsrechte für bestimmte Gruppen anzulegen. Danach konnte die Einspeicherung beginnen.

Ich habe derweil ein paar Performance-Messungen vorgenommen. Die grundsätzlichen Results waren für den Preis schon recht gut. An einem 8-Port-Gigabit-Switch von SMC ergab sich im Mittel eine Transferrate von ca 15-20MB/s von einem Windows XP Rechner auf das NAS(Schreibend) und ca 20-25MB/s in die Gegenrichtung (Lesend).

Ohne jegliche Modifikationen an der Lüftersteuerung ist der Lüfter immer an. Leider auch wenn die Festplatten schon längst abgeschalten haben (also z.B. nachts, wo es doch ein wenig stört, wenn ein Lüfter rumröhrt). Dank einer kleinen Modifikation in der Lüftersteuerung (Artikel) war jedoch auch dies zu beheben.

Alle Artikel zum CH3SNAS sind über den entsprechenden Tag zu erreichen.

Veröffentlicht von

Uli

IT-Nerd und Admin

121 Gedanken zu „Conceptronic CH3SNAS“

  1. Hallo Uli,

    hast du schon Erfahrungen mit dem Print-Server gemacht? Kann man da einen beliebigen USB-Drucker anschließen? Auf der Website von Conceptronics sind nur einige wenige angegeben…

    Vielen Dank
    Grüße

  2. Hallo,
    leider nein, mein Drucker ist bereits netzwerkfähig. Meines Erachtens ist aber da ziemlich jeder USB-Drucker ok, sofern dieser von CUPS unterstützt wird.

    Grüße
    Uli

  3. hi uli!

    samma, kann ich auf dem gerät ohne grossartig wieder rumfrickeln zu müssen, nen torrent client installieren und wenn ja welchen und wie?

    dank und gruss

    stefan

  4. hallo uli,

    hab mittlerweile hab ich mir das gerät auch besorgt.
    alles bestens, ich hab nur mal 2 fragen:
    wie kann ich die rechte an am ordner start ( fun plug ) ändern das ich das lüfterscript dort ablegen kann ?
    und:
    ich komm beim kopieren nur auf 10 mb/s ( gigabit netzwerk ).
    er startet zwar mit 16mb/s geht dann aber runter auf 10 konstant.
    vielleicht hast ja ne idee !

    gruß carver

  5. Hoi,
    Leg das Lüfterscript einfach woanders ab (beispielsweise direkt auf der Platte und kopiere es einfach mittels cp an den richtigen Ort.

    Dein anderes Problem kann ich nicht nachvollziehen, bei mir gehen teilweise 2*18MB/s gleichzeitig auf das NAS… schau mal ob dein MTU-Wert auf deinem Rechner verstellt ist!

    Beste Grüße
    Uli

  6. so, ich mal wieder.
    gibt es eine möglichkeit für den ftp server ein logfile erstellen zu lassen ? nutze diesen recht häufig wenn ich mal unterwegs bin und ein paar tools brauche, aber würde gerne wissen ob ich wirklich der einzige bin bzw. wie oft mein kleiner darauf rumstiert 🙂

  7. Hi,
    vielleicht kannst Du mir bei meinem FTP Problem helfen…
    Ich habe einen FTP Account mit Passwort Freigegeben, und innerhalb meines Netzes kann ich mich auch mittels eines FTP Clients darauf zugreifen, indem ich die IP Adresse meines CH3SNAS eingebe. Nun zu meiner Frage, wie müsste die Adresse lauten, um den FTP Server aus dem Internet anzusprechen? Mit der WAN IP die mein Router hat, gefolgt von der CH3SNAS Adresse (z.b. 83.124.23.2/192.168.1.13) klappt es nicht.
    gruß
    Patrick

  8. Hoi Patrick,
    du musst eine Portweiterleitung in deinem Router einrichten. Darin musst du dann einen externen Port auf den FTP-Port (normalerweise 21) deines CH3SNAS weiterleiten. Die Adresse wäre dann z.B. 83.124.23.2 mit der Angabe deines externen Ports.
    Hoffe das hilft dir weiter!
    Beste Grüße
    Uli

  9. Hallo Ulli,
    super die Option hatte ich in meinem Router schon mal gefunden. Kann ich mir als externen Port kreativ einen aussuchen?
    Jedenfalls werde ich das nachher mal bei mir einrichten und hoffen das es klappt 🙂
    Hast Du schon mal den ddns service von z.b. dyndns.org in anspruch genommen? Das würde ja mal das lästige Suchen der WAN IP ersparen. Ich bin mir aber nicht sicher, was man dafür zahlt…

  10. Hoi,
    Ich verwende selbst dyndns und bin damit sehr zufrieden, da es das Handling mit dem CH3SNAS wirklich erleichtert. Der Externe Port kann frei gewählt werden, musst diesen halt entsprechend in deinem FTP-Programm angeben.
    Übrigens achte darauf nur mit neueren Firmwares ins Internet zu gehen (1.02 sollte man schon drauf haben), da erst diese einen sicheren FTP-Server verwenden. Du willst ja nicht, dass dein CH3SNAS missbraucht wird 🙂

    Beste Grüße
    Uli

  11. Hi,
    ich hab mir Deine Ratschläge zu Herzen genommen, und meinem Router / dyndns.org entsprechend eingerichtet.
    Seltsamerweise macht der FTP Server immer noch Probleme. Mittlerweile kann ich mich via eines FTP clienten einwählen (Fireftp / Filezilla und Vista) allerdings bekomme ich keine Files in meinem Ordner, geschweige denn den Ordner angezeigt. Nach einer Zeit x kommt ein timeout.
    Hast Du dazu irgendeine Idee?
    gruß
    Patrick

  12. Hi,
    das Einwählen ist schon mal gut, wenn das komplett klappt. Hast du einen Ordner angegeben, der normalerweise via FTP übers LAN erreichbar ist? (So kann man mal prinzipiell ausschließen, dass es ein Problem des NAS selbst ist). Wenn ja, dann musst du vielleicht „Passives FTP“ aus- oder anschalten (vobei ich eher ersteres vermute).
    Wenn es dann immer noch nicht klappt: Viele Router bieten vorgefertigte Konfigurationen für FTP-Durchleitung an, vielleicht kannst du da eine fertige nehmen.
    Beste Grüße
    Uli

  13. Hi Ulli,
    netzintern mit der privaten IP klappt das ftp prima. Vielleicht macht es Probleme, da ich mich mit dem ftp clienten immernoch im heimnetzt befinde und über die ddns domain wieder zurück zum router verbunden werde.
    Da muss ich noch etwas forschen…
    gruß
    Patrick

  14. Ach da liegt das Problem. Ja das wird nicht funktionieren, das macht bei vielen Leuten Probleme 🙂 Versuchs von extern, dann wirds vermutlich klappen 🙂

  15. Moin,
    so, nun bin ich auf der Arbeit und kann von hier aus noch nichteinmal meine dyndns.org domain anpingen (ganz zu schweigen davon, das der FTP client läuft) 🙁 Obschon ich der Meinung bin, das in die korrekte IP Adresse aufgelöst wird.
    Alles nicht so einfach…

  16. Auch via eines Internet Services antwortet mein router nicht auf den Ping… Entweder ich habe zuhause einen Stromausfall, oder die IP wird doch nicht richtig aufgelöst.

  17. Zuerst hätte ich gesagt, dass es vielleicht dran liegt, dass dyndns.org bei dir in der Arbeit gesperrt ist, aber wenn auch externe Dienste nicht pingen können…da ist dein letzter Kommentar gleichzeitig der Lösungsweg. Vielleicht direkt mit IP connecten (die du jetzt vermutlich nicht weisst) 😉

  18. Da hab ich nun zwei Infos bekommen 1. FTP wird Firmenintern geblockt und 2. Soll es wohl Router geben die nicht unbedingt auf Ping antworten. Aber da scheint es noch ein Problemchen mit der Portweiterleitung zu geben, meinem Router habe ich gesagt, das er öffentlich 111 auf 21 umleiten soll. Da versuche ich mal ob 21 öffentlich besser klappt.
    Ja, wer keine Arbeit hat…. 😉

  19. Zu 1.: FTP gesperrt sollte ja nicht das problem sein, normalerweise wird halt der Port 21 dann geblockt. Wenn du allerdings bei einer grossen Firma (wie ich) arbeitest, dann haben die ein geschicktes Intrusion Detection System, welches FTP-Commands im Datenstream erkennt und den Verkehr unterbindet. Das waere dann ein Fall fuer FTP ueber SSL (dann wirds aber auch kompliziert, wenn du das CH3SNAS verwenden willst)
    Zu 2.:Alle Homerouter blocken Pings usw aus dem Internet, daher verwundert mich das nicht weiter. Dadurch, dass du aber eine Portweiterleitung eingerichtet hast, sollte es eigentlich ueber die 111 problemlos funktionieren. Mach doch einfach mal einen Portscan auf deinen Router (stelle sicher, dass du deinen Router scannst!) und schau, ob 111 offen ist. Wenn ja, dann liegt das Problem vielleicht am CH3SNAS.

    Tja ich mach grad Urlaub, von daher hab ich auch keine Arbeit 😉

  20. Das wird schon nicht nur das blocken des 21er Port sein, da ich ja 111 genommen habe… ich muss auch nicht unbedingt von der Arbeit aus darauf zugreifen können, ist halt nur ein Versuch gewesen, da ich hier ja ein anderes Netz und etwas Zeit (in der Pause natürlich 🙂 ) habe.
    Meine beiden Hoffnungen sind jetzt, das ich den öffnetlichen Port 111 auf 21 ändere und eventuell einen anonymen Zugang zu Testzwecken zulasse.
    Das Leben könnte sooo einfach sein, ohne Computer 😉

  21. Okay, anscheinend hatte mein Router den Port 111 nicht so recht lieb gewonnen. mit 21 öffentlich auf 21 privat klappt es nun endlich.
    Danke für Deine Unterstützung Uli.

    Gruß
    Patrick

  22. Hmm, soweit, so gut. Aber hast Du vielleicht eine Idee warum das mit dem IP-forwarding nicht klappt?
    Desweiteren steht auf meiner todo-Liste, heraus zu bekommen, wie ich meinem Router beibringen kann, sich nach einer Zeit der Inaktivität automatisch wieder zu verbinden.
    Aktuell unterbricht er die Verbindung nach ca. drei Stunden und dann habe ich von „ausserhalb“ keine Chance mehr auf den CH3SNAS zu gelangen.

  23. Das Forwarding ist mir ein Rätsel, da ich selbst das ja auch nutze. Welchen Router nutzt du denn? Dann wäre auch die Frage nach der Inaktivität leicht zu beantworten. Ansonsten gäbe es noch einen Trick, dass das CH3SNAS eben von innen beispielsweise alle 30 Minuten einen Ping ausführt.

  24. Ich nutze einen Philips SNB6500, meine erste Amtshandlung war, die Zeit bis zur Trennung hoch zu setzten.
    Ich habe auf meinem CH3SNAS noch kein Fun plug laufen, und ich scheue mich ein wenig davor, da ich nur rudimentäre Linux-Konsolen Erfahrung habe.
    Nun, wie ich mich kenne werde ich mich irgendwann nicht zurückhalten können, letztendlich gibt es ja schon einige nützliche Programme dafür (z.b. die Lüftersteuerung)

  25. Also was ich grad auf die schnelle gelesen habe, sollte es eigentlich abschaltbar sein (normalerweise kann das jeder Router). Vielleicht, wenn man die Zeit auf 0 setzt? Ich kenne leider den Router nicht genau, sonst könnte ich dir genaueres sagen. Such mal nach einem Firmware Update, vielleicht hilft das ja.

    Das Fun_plug ist total unkompliziert und lohnt sich wirklich 🙂

  26. Ich habe gestern das CH3SNAS bekommen, mit 2 Samsung 750GB Platten. Hat insgesamt mit Versandkosten 330Euro gekostet. Habe auch noch Gestern das neue Firmware (1.0.3 Final) installiert sowie das fun_plug 0.4.
    Telnet, scp sowie ssh tun, nfd und die rcp Dienste sind gestartet. Mein grosses Problem ist folgende Fehlermeldung bei mount_nfs (sowohl dbox wie einem freebsd Rechner); mount: RPC: Timed out. Leider konnte ich bei Google nichts finden. Kann mir da jemand weiterhelfen, ich habe einige Unix Rechner im Netz und weiß jetzt ehrlich gesagt nicht weiter.

    Danke im Voraus.

  27. Hallo Vaxmaster,
    leider weiss ich da auch kein Mittel dagegen, sollte sich hier nicht ein Besucher melden, würde ich dir raten, dich mal im DNS323-Forum zu melden.
    Beste Grüße
    Uli

  28. Hallo Uli,

    eine allgemeine Frage zu dem guten Teil – habe nun das Lüfterscript installiert, kopiere nun Daten auf das gute Stück. Ausgerüstet ist das NAS mit 2 x 500 GB Samsung Platten.
    Nun habe ich seltsamerweise folgenden Effekt: Nach ca. 180 GB draufkopieren bekomme ich auf meinem Windoof-Rechner die Meldung, die Platte wäre voll.
    Übers Webinterface zeigt das NAS unter Status->Harddrive Info nur einen leeren Rahmen an. Unter Tools->Scandisk und ausgelöstem Scanvorgang erhalte ich die Fehlermeldung: Hard Drive(s) Scanning Failure
    Nach einem Neustart und einem Blick auf dem Menuepunkt Tools->Raid sehe ich: The RAID volume is synchronizing now. Please wait for xx minute(s).
    Kann es sein, das bei „exzessivem“ Kopieren auf die Platten das Teil abschmiert ?!? Normalerweise werden nach meinem Verständnis doch beide Platten sofort, also zeitgleich beschrieben und nicht nacheinander abgelichen, oder ?!?
    Was kann hier die Ursache sein ?!?

    Gruss, Hannezz

  29. Sollte eigentlich direkt geschrieben werden, soweit ich das kenne. Das klingt bei dir extrem komisch. Hast du beide Festplatten gleichzeitig eingebaut oder erst eine und dann auf RAID upgegradet? Wenn deine Daten sofort wieder neu draufkopierbar sind, dann würde ich das NAS einfach nochmal frisch aufsetzen?

  30. Hallo Leute,

    ich habe einen CH3SNAS mit mit zur Zeit einer HDD und der Firmware 1.03 am laufen.
    fun_plug 0.4 läuft hervorragend und ist zur Zeit nur mit einem SSH Server und der Lüftersteuerung konfiguriert.
    Jetzt zu meiner Frage:
    Weis jemand wie ich mein NAS als Domain Controller konfigurieren kann?
    Ich habe bis jetzt nur die Anleitung von wiki.dns323.info gefunden, ich bräuchte aber ein auf deutsch.
    Hat da schon jemand Erfahrung damit?

    Mir geht es eigentlich hauptsächlich darum, dass ich zentral gespeicherte Benutzerprofile für meine XP Rechner habe.

  31. Hallo Georg,
    wenn du mir zu der Anleitung, die du gefunden hast, kurz den Link posten würdest, würde ich das selbst auch mal ausprobieren und vielleicht eine Anleitung schreiben!
    Beste Grüße
    Uli

  32. nabend, hab mein NAS jetzt schon ca. 6Monate und war eigentlich positiv angetan bis auf eines. Ich komm beim Daten übertragen auf noch nicht mal max. 3MiB/s. Hab jetzt das CH3SNAS Firmware Update 1.04RC5 drauf gemacht um zu schauen ob sich was ändert aber nix … Alles beim alten. Habt ihr vieleicht nen Tip. Mein NAS hängt an nem WLAN Netzwerk …

  33. Das ist wohl auch der grundlegende Fehler… du solltest es dringend über Kabel anschließen. 54Mbit-WLAN hat eine Übertragungsgeschwindigkeit von rund 5MB/s. Mit Routerverkehr usw vermutlich weniger, sodass 3MB/s eher normal sind.

  34. THX, das werd ich doch dann gleich mal ausprobieren. Auf was für Geschwindigkeiten kommt man denn dann so im Schnitt ?

  35. Hi,

    25 MB/s – Megabyte oder Megabit ?

    25 Megabyte entsprächen ja grob übern Daumen 200 Megabit ?!?

    Ich habe den Eindruck hier wird immer wieder zwischen Megabyte (MB) und Megabit (Mb) gewechselt ?!?

    Gruss,
    Hannezz

  36. so, mal ausprobiert und es funzt … komme auf ca. 16MB/s … so, und jetzt werd ich mir mal das fun plug anschauen ob ich das brauch ^^

  37. So… das mit dem Gigabit hat mir keine Ruhe gelassen – 15-30 Mbyte/sec erzeugte doch ein kleines Neidgefühl… – Ergebnis:
    Mit Gigabit-Switch ca. 12000 Kbyte, direkt verbunden NAS-GigabyteEP45-DS3R ergibt ca. 15000 Kbyte.
    Hat schon mal jemand mit den JumboFrames experimentiert ? Laufe ich da Gefahr, dass ich dann eventuell keinen Zugriff mehr aufs NAS habe ?!?

    Gruss, Hannezz

  38. So, nun habe ich – speziell beim Datenabgleich noch ein Problem mit der Uhrzeit: Nach Ausschalten des Geräts und wieder hochfahren ist das NAS eine Stunde voraus
    Gehe ich ins Menü Time -> auf Knopfdruck über ntp-server time.windows.com / GMT +1.00 h und aktuallisiere, dann stimmts wieder (Daylight saving time ist auf „EU“, also Sommerzeit eingestellt).
    Fahre ich die Kiste dann runter, schalte aus und starte später wieder, stimmt die Uhrzeit wieder um 1 Stunde nicht.
    Kann ich dem Teil beibringen, nach dem Booten selbstständig den NTP-Server abzufragen ?!?
    Weiss jemand Rat ?

  39. @Hannezz: JumboFrames müssen dann alle Netzwerkgeräte, die du mit der Netzwerkkarte erreichen willst (Swiches, Router usw) können, sonst wird das meines Wissens nicht gehen. Bei mir würde es bis auf den Router klappen, aber ich probiere es nicht aus.

    Bezüglich deines Zeitproblems schaust du am besten mal hier

  40. Hallo. Hat jemand von euch Erfahrungen mit dem CH3SNAS in verbindung mit einem Wlan Radio. Ich sehe die Alben, komme bis zu den Titeln und wenn ich einen Titel auswähle erscheint „Keine Verbindung.“ Mein Wlan Radio ist das Internetradio1 von TechniSat. Vielen Dank für eure Antworten.

  41. könnt ihr mal kurz detailhiert mal auflisten was das funplug so bringt bzw. was man dan alles damit machen kann ? in einer verständigen ausführung 🙂 … nich lachen … 😉

  42. @poschi-heinz:
    Wenn du des englischen mächtig bist, rate ich dir zu einem Lesen meines englischen wikis.

    Ansonsten stöbere mal ein wenig durch meine Beiträge zum fun_plug (auch den älteren Versionen).

  43. Hallo, ich will mir auch ein NAS-System holen und habe jetzt mal ein paar deiner Artikel durchgearbeitet. Vom Preis her scheint das CH3SNAS ja top zu sein. Bevor ich mir das Teil bestelle, müsste ich aber noch wissen, welche Plattenkapazitäten das Teil unterstützt. Ich will mir erstmal eine 1TB-Platte holen und später erweitern. Ist das ohne Probleme möglich?

    Und dann gleich noch eine Frage hinterher: Welche Maße hat das Gehäuse? Ich habe selbst beim Hersteller keinerlei Angaben dazu gefunden, oder übersehen 😉 Vielleicht ist ja einer von euch so freundlich und nimmt mal schnell ein Lineal in die Hand 😉

    Danke für deine Antwort.

  44. Hallo Carsten,

    ja 2*1TB ist bereits getestet worden und funzt bestens. Später erweitern habe ich selbst auch gemacht. Da es ein Linux da drauf ist, sehe ich auch nichts, was gegen größere Platten sprechen würde.

    Wegen der Maße in etwa:
    B: 10cm
    H: 13cm
    T: 20cm

  45. Hallo zusammen,

    ich hab auch eine Frage und zwar:

    Es gibt so wie es aussieht zwei Versionen vom CH3SNAS. Also ein Mal die hier vorgestellte und als Mediaserver.

    Macht es einen unterschied welches ich mir hole oder ist es egal? So wie ich das gesehen habe, sind die Funktionen identisch (wenn nicht berichtigt mich bitte)

    mfg Burst

  46. Hoi, beide Revision sind auf der Hardwareseite identisch, lediglich das Gehäuse ist unterschiedlich. Die hier vorgestellte Revision ist die ältere. Die neuere ist fast ein wenig hübscher 😉

    Greetz
    Uli

  47. Nachdem es mir auf meinem Ein-Laufwerk-NAS (Fantec LD-H35NU2) aus heiterem Himmel das Dateisystem zerschossen hat, habe ich mir aus Gründen der Datensicherheit ein CH3SNAS geordert.

    Bevor ich das CH3SNAS in Betrieb nehme, stellt sich mir die grundsätzlich Frage nach der Konfiguration des Geräts, um die Daten später möglichst SICHER zu lagern.

    Ich frage mich, ob der Betrieb des CH3SNAS im RAID1-Modus wirklich ein wirksamer Schutz vor einem spontanen Fehler im Dateisystem einer Platte ist. „Sorgt“ RAID1 vielleicht dafür, dass bei einem Fehler im Dateisystem der einen Platte auch die andere Platte unbrauchbar wird?

    Das CH3SNAS erlaubt es meines Wissens, beide SATA-Platten im „normalen“ Modus als einzelne unabhängige Laufwerke zu betreiben. Wünschenswert wäre für mich eine Software für das NAS/fun-plug, die ein (ggf. zeitgesteuertes) Backup des Inhalts einer Platte auf die anderen Platte ermöglicht? Dies wäre dann in meinen Augen die sicherere Lösung als der Betreib im RAID1.

    Mir viel hierfür das freie „Backupnetclone“ ins Auge. Lässt sich die Software auf dem .AS/fun-plug betreiben? Wenn ja, wo finde ich einen Anleitung für die Installation?

  48. Prinzipiell würde ich die zu zwei getrennten Platten raten. Genau wie du vermutet hast, kann durch einen Dateisystemsfehler der Inhalt beider Platten hops gehen.

    Fürs Backup kann ich gerne mal ein Tutorial schreiben. Prinzipiell reicht für einen einfaches Datenkopieren schon der Befehl:

    rsync av /mnt/HD_a2/ /mnt/HD_b2

    aus. Dieser kann regelmäßig per cron ausgeführt werden und sichert so die Daten. Etwas ausgefallenere Optionen kann das Programm rsync natürlich auch noch 😉 Bedingt natürlich, dass man das fun_plug angeworfen hat 😉

  49. Vielen Dank für die Bestätigung meiner Vermutung. Damit ist RAID1 für mich aus dem Rennen. Toll, dass es die Möglichkeit gibt das Backup per Terminal manual zu iniitieren.

    Ein Tutorial wäre natürlich ganz groß. Ich würde mich freuen, wenn Du die Zeit fändest. Mir scheint rsync hat sich schon jetzt einen Platz auf meinem funPlug erarbeitet 🙂

  50. Hi,

    seit ein paar Tagen habe ich das CH3SNAS (neue Version) mit zwei WD10EACS. ‚fun_plug‘ 0.5 funktioniert soweit, aber von der Geschwindigkeit bin ich nicht begeistert. Lokal kopiert zum Beispiel ‚mc‘ von einer auf die andere Platte nur mit 9.5 MBytes/s.

    Außerdem frage ich mich wie die Leute auf 500 MHz kommen, ‚dmesg‘ zumindest gibt ‚Sys Clk = 166000000, Tclk = 166000000‘ aus.

  51. Die Prozessorspezifikation lautet auf 500Mhz, daher kommen die Leute da drauf 😉

    Das mit dem Kopieren ist allerdings ungewöhnlich, das geht auch bei mir schneller…vielleicht Gerät defekt?

  52. Hallo!
    Hab jetzt seit einiger Zeit das CH3SNAS und war bis jetzt sehr zufrieden damit bis auf die Lautstärke. Funplug mit Lüftersteuerung hab ich mich noch nicht getraut, deshalb war das Ding in der Nacht immer aus. Beim letzten Einschalten waren auf einmal die Freigaben weg! Anmelden am Gerät über IP ist aber Möglich, obwohl das Gerät nicht unter „Arbeitsgruppencomputer“ aufscheint.
    Nach einem „Zurücksetzten in den Auslieferungszustand“ waren die Freigaben wieder da, allerdings nur 5 Minuten.
    Dann wieder „Netzwerkpfad nicht gefunden“ auf beiden XP Pro Rechnern im Netz (an Netgear WLAN Router).
    Reboot der Rechner, des Routers und der NAS bringt nichts,
    nur das Zurücksetzen der NAS lässt mich für kurze Zeit auf die Daten zugreifen.

    Whats up?

    Gruß,
    Johannes

      1. Ach ja, Danke! War noch Version 1.02 von 2007.
        Hab jetzt 1.04RC5 reingespielt, seit dem alles normal.
        Komisch nur, dass die alte Firmware so lange funktioniert hat und plötzlich nicht mehr.
        Jetzt gehts auf jeden Fall, ich hoffe das bleibt so!

        Gruß,
        Johannes

  53. Hallo Christoph,
    ich habe das gleiche Problem mit einem Frecom WLAN Mediaserver.
    Hast Du eine Lösung gefunden, dann schreib sie bitte.
    Grüsse Uwe

    1. Hi Uwe, ich habe leider keine gute Lösung gefunden. Ich habe das Funplug aufgespielt und den dortigen Mediaplayer probiert. Er hat aber nicht alle Musik-Dateien eingelesen. Dann habe ich den Twonky Mediaserver aufgespielt. Das Problem hier ist auch wieder, dass mein Abspielgerät den UPnP Server nicht von selbst erkennt auch wenn ich die Ip eingeben. Problem 2 ist das die Platten seit dem durchlaufen. Wenn jemand eine gute Lösung hatt bitte „MELDET EUCH“ Danke.

      1. Hallo Christoph,
        wie hast Du das mit dem einlesen von Musikdateien in den mediatomb gemacht? Ich will es einfach mal nachvollziehen.

        1. Im Nas Wiki ist eine Erklärung wie Mediatomb aktiviert wird. Das hab ich gemacht und die Verzeichnisse angegeben die ich hören möchte. Mein Problem ist das ich mein Internetradio an mache und er den Mediatomb server nicht von selbst erkennt. Erst wenn ich den Pc angemacht habe. Auch wurden nicht die ganze Musik angezeigt. Von dem squeezecenter hab ich noch nichts gehört. Gibt es ein Tutorial dazu? Am liebsten würde ich nur den Upnp vom NAS nehmen, aber da gibt es die selben Probleme wie mit Mediatomb.

  54. Hallo zusammen,

    ich wollte mir demnächst auch ein CH3SNAS kaufen uns habe vorab eine kleine Frage.

    Kann ich eine bereits gefüllte Festplatte in den CH3SNAS schieben oder muss diese durch das Gerät erst formatiert werden?

    Dank,
    Larsen

  55. Hallo,

    kannst du mir auch etwas zum Stromverbrauch der NAS sagen ?
    also z.B:
    bei aktiven Festplatten mit Zugriff
    bei aktiven festplatten ohne Zugriff
    bei inaktiven Festplatten (Spin down oder Ruhemodus)

    Leider finde ich hierzu recht wenig angaben
    mir ist schon klar das der Verbrauch mit FP nartürlich auch von den eingesetzten FP abhängig ist.
    (ich habe gelesen das du 2 x500 GB Platten angeschlossen hast)

    wann fahren die Festplatten in den Ruhe modus (ist das einstellbar?).

    herzlichen Dank für deine Bemühungen
    gruss Pid

    1. Hi,
      ich werde mal ein paar Messungen machen, aber soweit ich das grad im Kopf habe, braucht das NAS bei ausgeschalteten Platten etwa 8W. Insofern ist der Verbrauch nicht so wild 😉
      Das Ausschalten der Festplatten ist in definierten Werten einstellbar, ich habs momentan auf 30 Minuten stehen.
      Viele Grüße
      Uli

  56. Hallo

    Kann ich von meinem PC aus mit Winamp, PowerDVD und VLC einfach die Datein abspielen die auf dem NAS lagern oder muss man die erst auf den PC kopieren oder sonstwie abändern?

    Gruss

  57. Hallo Uli,

    mein Dad hat gestern eine CH3SNAS gekauft, dort ist momentan eine 1TB Festplatte untergebracht. Im Netzwerk läuft das Teil einbahnfrei =)

    Meine Frage ist folgende:
    Auf der Platte liegt ein ordner auf den mein Freund auch Zugang haben soll, ich dachte mir ich mache das via FTP. Wie richte ich nun den FTP Server ein? Kann man die Platte dann immer noch normal via LAN nutzen?

    Wenn er nun eingerichtet ist und alles geht, kann ich dann auch User anlegen, die lediglich auf bestimmte Ordner Zugriff haben oder nur bestimmte Ordner sehen?

    Liebe Grüße Mirco

    1. Hi Marco,
      durchforste mal das Webinterface, es gibt dafür einen eigenen Punkt. Ja du kannst alle Services gleichzeitig nutzen 😉

      Viele Grüße
      Uli

  58. Hallo Uli

    Nu hab ich auch noch ne Frage. Wenn ich an das Gerät die 230V anlege, ist es dann sofort betriebsbereit oder muss ich erst ein Netztaster drücken, um es zu starten?
    Danke schon mal für die Antwort

    Gruß
    Marco

    1. Hi Marco,

      genau das Problem hab ich vor kurzem gehabt als ich in Urlaub war und auf meine Daten zugreifen wollte.
      Nach einem Stromausfall war zwar die FritzBox wieder Online, aber der CH3SNAS muss leider mittels Tastendruck wieder aktiviert werden.

      Frage an alle:
      Gibts da irgendeine Möglichkeit, dass sich der CH3SNAS nach einem Powerloss wieder von selbst einschaltet?

      1. Wake-On-LAN ist leider nicht möglich (ohne zusätzliche Bauteile). Das einfachste wäre wohl das Löten von einer Schaltung an den Einschalter, die folgendes macht:
        – Anlegen von Strom bewirkt das Schließen des Druckschalters an der Vorderseite für eine (oder mehr) Sekunden.
        – Solange Strom angelegt ist, ist die Schaltung inaktiv und wird nicht nochmals auslösen.
        – Fällt der Strom ab, wird die Schaltung zurückgesetzt und löst bei erneutem Stromeinschalten dann wieder den obig genannten Vorgang aus.

        Konkret müsst ich da mal meine Unterlagen durchsuchen, ich hatte da mal was…

        Edit: ThreadSchaltung

        Viele Grüße
        Uli

        1. @Uli
          danke für den Link mit dem Schaltplan.
          Ich hätte gedacht, dass es da evtl. eine Lösung über Funplug gibt.
          Bei vielen Mainboards gibt es ja auch eine Möglichkeit im BIOS für „Power up after Power loss“

          Ich werd jetzt mal den Schaltplan nachbauen und das ausprobieren.

  59. Hallo,
    endlich habe ich auch mein CH3SNAS.
    Kann ich denn jetzt eine Platte reinhängen (1TB) und dann später nochmal eine Platte, ohne das ich nochmals formatieren muß?
    Ich benötige keine Raid-Funktionalität.

    mfg
    Tim

  60. Hallo! Ich kommen mit Telnet nicht auf mein CH3SNAS. Ich gebe aus einem „CMD-Fenster“ ein „Telnet IP-Nummer“, erhalte aber nur die Meldung, dass eine Berbindung über Port 23 nicht möglich/ fehlgeschlagen ist.
    Danke

    1. Hi,
      zu einen: Das hat nichts mit der Hardware zu tun, bitte stelle deine Frage in dem Beitrag, wo es auch passt (fun_plug). Zum Anderen: Bitte nimm PuttY für den Verbindungsaufbau.
      VG, Uli

  61. Hallo, nach Studium Deiner Seite hab ich mir (als absoluter Laie) doch das Teil geleistet. Funktioniert prima. Inzwischen hab ich von 2 PC ein Netzlaufwerk auf ein Verzeichnis auf dem NAS verbunden und dafür auch Berechtigungen (User/Passwort) eingerichtet und bin dabei auf ein Problem gestoßen:
    Wenn ein PC neu gestartet ist, ist die Verbindung zum NAS weg und ich muß mich erst wieder über den Login-Dialog anmelden. Kann man das automatisieren? Gibt´s dafür vielleicht eine Batch-Datei?
    Grüße
    Gerhard

  62. Hallo,

    ich habe mal eine Frage wegen Zusatzprogramme auf dem NAS und was möglich ist. Leider ist Linux (läuft wohl auf dem NAS) nicht meine Welt und ich brauche Hilfe.

    Ich habe mein Netzwerk vom Megabit-LAN auf Gigabit-LAN umgerüstet. Wahrscheinlich völlig normal aber ich bin von der Geschwindigkeit völlig enttäuscht. Ich merke keinen Unterschied vom 100 zu 1.000 Mbit Netzwerk.

    Nun wollte ich gerne mal die Netzwerkgeschwindigkeit messen. Dazu gibt es ein Programm Namens „iperf“

    http://www.heise.de/software/download/iperf/28370

    Gibt es eine Möglichkeit diese (Linux?) Programm auf dem NAS laufen zu lassen um die Verbindungsgeschwindigkeit zu den Windows Cients zu testen?

    Über Tips wäre ich sehr dankbar.

    Gruß

  63. Hi,

    gestern war bei mir Murphy zu Gast…die Übertragung einer Datei zum NAS (2x 1TB, RAID1, FW 1.04) abgebrochen – sollte ja eigentlich nix bei passieren. Komisch war: die Datei war danach trotzdem da (?sollte die nicht automatisch gelöscht werden, wenn die Daten nicht vollständig ankommen?). Als ich die Datei dann löschen wollte, hat sich der Explorer weggehängt. Nach Neustart des NAS ließ sich die Datei löschen, aber beim erneuten Versuch der Übertragung ist diese wiederum abgebrochen (hallo, Onkel Murphy), und wieder selbiges Verhalten wie oben.

    Mittlerweile traue ich dem Dateisystem nicht mehr so ganz, also wollte ich ‚mal per SSH auf die CH3SNAS und dort ein fsck laufen lassen (geht das überhaupt so einfach?), aber nach dem Login erhalte ich kein command prompt, sondern die CH3SNAS meldet nur:

    login as: root
    root@ch3snas's password:

    BusyBox v1.00-pre1 (2008.03.21-07:56+0000) Built-in shell (ash)
    Enter 'help' for a list of built-in commands.

    und das isses dann. Irgendjemand ne Idee?

    Gruß,
    Sascha

  64. Hey, ich habe das funplug auf USB-Stick installiert und wollte nun mediatomb starten. Das home Verzeichnis liegt aber somit noch auf usbstorage. In der Config steht: /ffp/var/mediatomb
    Die befindet sich direkt ausgedürckt unter: NAS–>Volume_1–>usbstorage
    Meine Daten befinden sich aber direkt auf Volume_1 in anderen Unterordnern, wie mache ich dem Server dieses Home-Verzeichnis schmackhaft?

  65. Frage an alle Twonky Nutzer!

    Wie deaktiviere ich den Twonky Server temporär oder auch dauerhaft?? Ich kann Befehle eingeben wie ich will, Twonky läuft und läuft.

    Reicht es aus, wenn ich die starttwonky.sh im /mnt/HD_a2/ umbenne?

  66. Hi,

    ‚mal wieder ich – habe folgende Problemstellung mit dem CH3SNAS:

    habe hier einen Folder eingerichtet, in dem nur 4 Dateien sind, auf den anonymous ftp Leserechte hat.

    Jetzt habe ich ausserdem seit kurzem erst andere ftp Folder eingerichtet und User/Pw geschützt und den Zugriff von extern über Portforwarding eingerichtet. Soweit läuft auch alles, aber leider hat natürlich auch jeder dahergelaufene auf diese Weise Zugriff auf den anonymous-Folder. Kann ich die ganze Geschichte irgendwie so konfigurieren, dass nur lokale IPs anonymous-Zugriff haben?

    Gruß,
    Sascha

  67. CH3SNAA als Mali-Server?

    Kann man sich vorstellen, das CH3SNAS als IMAP-Mailserver zu betreiben (Einsammeln der Mail von externen POP/IMAP-Konten via fetchmail, vorhalten der Mails per postfix als IMAP-Server)? Oder spricht prinzipiell etwas gegen diesen Lösungsansatz?

    Gruß
    Martin

    1. Da spricht nix dagegen, prinzipiell geht das 🙂 Müsste man halt mal ausprobieren bzw. die entsprechenden Tools kompilieren. Nur als IMAP-Server taugt imho postfix nix, da es das nicht kann. Dazu würde ich dovecot,qmail oder courier verwenden.

      Viele Grüße,
      Uli

      1. Nach langem Suchen scheint die Kombination

        – fetchmail
        – postfix
        – devcot

        eine geeignete Lösung zu sein. Allerdings habe ich für keines der Produkte ein CH3SNAS / DNS323 package gefunden. Irgend eine Idee, wo man das finden kann, bevor ich mich ans Kompilieren und Testen mache?
        Gruß
        Martin

          1. Vielen Dank für die Info!
            Wenn ich Zeit habe, werde ich mich an dieses (scheinbar) größere Projekt mal ranwagen.
            Mein erster Anlauf hat mich schon mal ein paar Stunden gekostet: ich wollte mein NAS einfach nur plattmachen (von RAID1 auf zwei Platten umkonfigurieren). Fehler: ch3snas „hard drive(s) formatting failure“.
            Ich beschreibe nicht alle Versuche, die ich unternommen habe. Irgendwo in den Tiefen des Web habe ich dann den Hinweis gefunden: man muss funplug deaktivieren, sonst ist die Disk gesperrt.
            Martin

  68. Hallo,
    da mein Problem thematisch nirgendwo richtig reinpasst stelle ich die Frage hier…

    möchte streamripper per cronjob ausführen

    der streamripper-befehl:

    streamripper http://ndr.ic.llnwd.net/stream/ndr_ndrkultur_hi_mp3 -d /mnt/HD_a2/radiorips/ -l 60 > /dev/null 2>&1

    wird auf der ssh-Konsole prima ausgeführt (60 sek nur zu testzwecken)
    in cron jedoch nicht.
    cron funktioniert:
    34 14 * * * mkdir /mnt/HD_a2/testdir

    aber der streamripper-Befehl in der crontab wird nicht ausgeführt.
    Frage mich jetzt, ob es Rechtekonflikte zwischen cron und streamripper gibt.
    mir fällt auf, daß das incomplete-Verzeichnis, welches SR anlegt root gehört (drwxr-xr-x)

    Langes googeln: Niemand scheint dieses Problem zu haben.
    Daher denke ich, daß ich vermutlich an der falschen Stelle nach dem Fehler suche.
    Bitte stelle mir doch die richtigen Fragen..

    Vielen Dank

    Florian

    1. Hi,

      gib mal den Pfad zum Streamripper im Cronjob komplett an. Suche diesen per „which streamripper“ und gib den Pfad, der ausgespuckt wird, im Cronjob an.

      Viele Grüße,
      Uli

      1. Perfekt, das ist es!
        Dank Dir.
        Also kein Rechteproblem sondern ein Problem der Pfadangabe.
        Warum aber benötigt cron den absoluten Pfad und der Konsolenbefehl nicht
        klärst Du mich auf?

        btw: Deine Tutorials und Deine immer geduldigen, freundlichen und lehrreichen Hilfestellungen sind außergewöhnlich! Ein großes Lob und dicken Dank dafür!
        Es würde sich lohnen aus den vielen Threads ein „Rundrumsorglos“-Handbuch zu erstellen. Das wäre noch eine Marktlücke.

        Florian

Kommentare sind geschlossen.