Ankündigung von Uli’s Funplug 0.7 Repository

Seit ffp 0.7 gibt es nun die Möglichkeit, dass man über das Zusatzprogramm slacker verschiedene „sites“ einbinden kann, welche Pakete bereitstellen. Nachdem ffp0.7 nun schon einige Zeit verfügbar ist, habe ich mich entschlossen meine Pakete auf ffp0.7 neu zu kompilieren.

Werbung

Wie kann man das Repository einbinden?

Automatisch

Das repository kann per uwsiteloader schnell eingebunden werden:

wget http://wolf-u.li/u/441 -O /ffp/bin/uwsiteloader.sh
chmod a+x /ffp/bin/uwsiteloader.sh
uwsiteloader.sh

Im Menü muss nun „Uli“ ausgewählt werden:
Ulis repository im uwsiteloader

Manuelle Einbindung

Inhaber Variante Sitename URL
Uli arm uli rsync://funplug.wolf-u.li/funplug/0.7/arm/packages

Veröffentlicht von

Uli

IT-Nerd und Admin

14 Gedanken zu „Ankündigung von Uli’s Funplug 0.7 Repository“

    1. Hi Mijzelf,

      As far as i remember it had to do with cairo, but that was a while ago. And cairo was needed for something else which i dont remember but it had to do with rendering canvas using nodejs 😉

      Cheers,
      Uli

  1. Servus,

    wollte gerade Dein repository einbinden, allerdings zeigt mir der uwsiteloader Deines nicht als Auswahlmöglichkeit an. Ich habe nur folgende Möglichkeiten:

    │ │[*] fonz rsync://ffp.inreto.de/ffp/0.7/oarm/packages │ │
    │ │[ ] Mijzelf http://downloads.zyxel.nas-central.org/Users/Mijzelf/FFP-St│
    │ │[ ] Memiks http://ffp.memiks.fr/pkg/oarm/ │ │

    An die manuelle Konfiguration habe ich mich mangels Linux-Plan nicht rangetraut.

    Gruß,
    Sascha

  2. Nachdem ich „uwsiteloader.sh“ ausgeführt habe kommt nach dem screen mit

    „Downloading definitions Completed – Processing“

    das er abbricht da kein Speicher zur verfügung steht…

    Es handelt sich um ein DNS-320 , aber als eingefleischter Windowsnutzer habe ich keine Ahnung wie ich da etwas beheben kann.
    Denn außer ein paar vergebliche versuche den mc zum laufen zu bekommen habe ich nichts installiert.

    Ich danke schonmal für deine Hilfe und deine Geduld mit WinDAUs ^^

    lg Marco

  3. Mir geht’s genau wie Sascha, allerdings auf einem DNS-343. Liegt das vielleicht daran, dass es sich um ein Gerät mit der „alten“ Prozessorarchitektur handelt (OABI) und keine oarm-Packages in Deinem Repo vorliegen?

    Jörg

  4. Hallo Uli,

    zunächst mal vielen Dank für die großartige Arbeit – erst dadurch ist meine DNS-320 überhaupt richtig nutzbar geworden!
    Gestern abend habe ich einige Stunden damit verbracht, den längst überfälligen Upgrade vom fun_plug05 auf 07 durchzuführen, weil ich den Twonky ausprobieren wollte. Es lief dann auch alles, nur leider hat offenbar auch Twonky ein Problem, JPGs mit den Informationen aus den EXIF-Daten korrekt zu rotieren. Schade, aber Schwamm ‚drüber. Ich wollte also zurück zu Mediatomb und da gingen dann die Probleme los.
    Das Paket mit Slacker zu installieren war kein Problem, aber die komplette Konfiguration war leider unbrauchbar. mediatomb.sh hatte als einzige option –daemon im Start-Script, was natürlich nicht ausreicht, weil der Ordner mit dem config-file (und der Datenbank) ja nicht im home/root (also im flash), sondern auf der Platte liegen muss. Weiterhin wurde libCurl nicht gefunden, die aber problemlos nachzuinstallieren war (aber wozu dann ein Package? sollte das mediatomb Package nicht in sich konsistent und vollständig sein?). Das Startup-Script also geändert, entsprechende Verzeichnisse manuell angelegt bzw. kopiert und dann gab es zumindest keine Fehlermeldungen mehr. Trotzdem wollte Mediatomb sich nicht mit dem Webinterface melden und am Ende bin ich dann entnervt zurück zu fun_plug05, wo Mediatomb ja „ab Werk“ sauber integriert war. Was habe ich falsch gemacht?
    Wie kann ich unter 05 zumindest mal einen Update des Mediatomb durchführen?
    Die übrigen Verbesserungen in 07 brauche ich nicht unbedingt …

    Vielen Dank und Grüße,
    Torsten

    1. Hi Torsten,

      die Pakete sind in sich nicht komplett, du musst die Abhängigkeiten selbst installieren. Da das Paketmanagement relativ rudimentär ist, gibt auch keine „Abhängigkeitsdefinitionen“ oder so etwas.

      Mediatomb ist leider nicht von mir, daher keine Ahnung wie das Paket gestaltet ist. Müsste ich mir ansehen…

      Viele Grüße,
      Uli

  5. Hallo ich habe auch ein dns-320 und diverse Probleme damit. Dibt es dafür ein belebtes Forum über installations hilfen und einrichten der softwares?

    mfg


  6. root@NSA310S:~# slacker -UaA uli:uwchmod
    Updating package lists...
    fetch: rsync -q 'rsync://ffp.inreto.de/ffp/0.7/arm/packages/CHECKSUMS.md5' '/ffp/funpkg/cache/s'
    fetch: (cd '/ffp/funpkg/cache/mz'; wget -Nnv 'http://downloads.zyxel.nas-central.org/Users/Mijzelf/FFP-Stick/packages/0.7/arm/CHECKSUMS.md5')
    fetch: rsync -q 'rsync://funplug.wolf-u.li/funplug/0.7/arm/packages/CHECKSUMS.md5' '/ffp/funpkg/cache/uli'
    fetch: (cd '/ffp/funpkg/cache/kylek'; wget -Nnv 'http://kylek.duckdns.org:31337/files/ffp/0.7-arm/CHECKSUMS.md5')
    fetch: (cd '/ffp/funpkg/cache/memiks'; wget -Nnv 'http://ffp.memiks.fr/pkg//CHECKSUMS.md5')
    http://ffp.memiks.fr/pkg/CHECKSUMS.md5:
    04:09:18 ERROR 404: Not Found.
    FATAL: memiks: No CHECKSUMS.md5
    root@NSA310S:~# ^C
    root@NSA310S:~#

    is there a fix for this error?

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.