ProFTPd (mit SSL/TLS) auf dem Conceptronic CH3SNAS bzw. D-Link DNS-323

Ich bin gebeten worden, doch bitte ein Tutorial bezüglich eines Ersatz-FTP-Servers mit SSL-Verschlüsselung zu verfassen. Diesem Wunsch komme ich gerne nach und zeige nun im folgenden, wie man ProFTPd einrichtet. Trotzdessen würde ich gerne drauf hinweisen, dass die internen FTP-Server des CH3SNAS und DNS-323 bereits AUTH TLS (FTPES) zur Verschlüsselung des Loginvorgangs unterstützen! Jedoch ist während dem Transfer im Datenstrom KEINE Verschlüsselung an, nur der Kontrollkanal wird verschlüsselt!
Ein Wort der Warnung noch: Leider bietet die CPU des NAS in Verbindung mit ProFTPd nur eine Geschwindigkeit von etwa 1,5MB/s.

fun_plug 0.5 ist veraltet und sollte nicht mehr genutzt werden! Dieses Tutorial ist daher ebenfalls veraltet! Bitte sehe hier nach den aktuellen Tutorials!

Werbung


Das Tutorial setzt voraus, dass fun_plug installiert wurde und mein Repository entsprechend der Anweisungen synchronisiert und aktualisiert wurde.
Die Installation gestaltet sich dann extrem einfach:

funpkg -i /ffp/pkg/additional/net-ftp/proftpd-*.tgz

Die Datei /ffp/etc/proftpd.conf muss noch erstellt werden:

cp /ffp/etc/examples/proftpd.conf /ffp/etc/

Jetzt müssen wir noch eine zusätzliche Gruppe erstellen:

groupadd nogroup

Wir brauchen jetzt noch das SSL-Zertifikat:

openssl req -new -x509 -days 365 -nodes -out /ffp/etc/proftpd/proftpd.cert.pem -keyout /ffp/etc/proftpd/proftpd.key.pem

Anschließend werden verschiedene Fragen bezüglich des Zertifikats gestellt. Die fettgeschriebenen Antworten sind Beispiele von mir. FQDN steht dabei für den hostnamen des NAS, die Fragen ohne Antworten können auch leer gelassen.

Country Name (2 letter code) [AU]: DE
State or Province Name (full name) [Some-State]: Germany
Locality Name (eg, city) []:
Organization Name (eg, company) [Internet Widgits Pty Ltd]: Name der Organisation
Organizational Unit Name (eg, section) []:
Common Name (eg, YOUR name) []: FQDN
Email Address []:

Um nun SSL/TLS zu aktivieren, müssen die Kommentare von den folgenden Zeilen in der Datei /ffp/etc/proftpd.conf entfernt werden:

<IfModule mod_tls.c>
TLSEngine                  on
TLSProtocol                SSLv23
TLSOptions                 NoCertRequest
TLSRSACertificateFile      /ffp/etc/proftpd/proftpd.cert.pem
TLSRSACertificateKeyFile   /ffp/etc/proftpd/proftpd.key.pem
TLSVerifyClient            off
TLSRequired                off
</IfModule>

Möchte man ausschließlich TLS verwenden, so muss in der letzten Zeile am Ende statt off auf on geändert werden.

Wie immer kann der FTP-Server nun so gestartet werden:

sh /ffp/start/proftpd.sh start

Die dauerhafte Aktivierung ist natürlich auch möglich:

chmod a+x /ffp/start/proftpd.sh

Übrigens: ProFTPd greift auf die gleichen Einstellungen wie der interne FTP-Server zu. Diesen kann man dann abschalten.

Das wars 😉

Veröffentlicht von

Uli

IT-Nerd und Admin

53 Gedanken zu „ProFTPd (mit SSL/TLS) auf dem Conceptronic CH3SNAS bzw. D-Link DNS-323“

  1. Moin Uli,

    nicht die Datei „/ffp/etc/proftpd.sh“ sondern
    „/ffp/etc/proftpd.conf“ muss editiert werden.

    Du schreibst außerdem das man den internen FTP Server abschalten kann … schalte ich ihn nun aber über das Webinterface von meinem CH3SNAS aus so habe ich keinen Zugriff mehr … ich nehme an das du das anderst gemeint hast oder?

    MfG

    Max

  2. Hi Max,
    ersteres habe ich aufgenommen, da hast du natürlich vollkommen recht.

    Bezüglich des Abschaltens: Hat bei mir hervorragend funktioniert, insofern weiß ich nicht, warum es nicht gehen sollte? Ändert sich bei dir etwas an der /etc/passwd wenn du den FTP abschaltest?

    Viele Grüße
    Uli

  3. Hi Uli,

    unter /etc/ gibt es bei mir keine datei bzw. ordner mit namen „passwd“.

    Ich hab jetzt aber etwas herumprobiert und eine Meldung erhalten das er beim starten die „nogroup“ nicht kennt bzw. findet … nachdem ich sie angelegt habe kann ich wieder per FTP Client zugreifen.

    Ich nehme mal an das es ein Rechte Problem ist richtig?!

    Wenn jemand dann mal wieder so nett wäre und die Lösung posten könnte oder mir meinen Fehler aufzeigen könnte wäre prima.

    Dann allen ein Frohes neues Jahr noch an der stelle.

    MfG

    Max

    1. Hi,
      das mit nogroup ist richtig, ich habe das korrigiert. Ausserdem habe ich das Vorwort erweitert, da möglicherweise vielen nicht klar ist, dass der interne FTP-Server des NAS bereits TLS kann 😉
      Und unter /etc/ gibt es garantiert eine Datei mit dem Namen passwd:

      cat /etc/passwd

      Sonst hättest du keinen Zugriff auf den FTP-Server 😉

      Viele Grüße
      Uli

  4. Hallo Uli,
    ich habe ein Problem beim starten des Servers. Wenn ich den Server von Hand starte, muss ich den Befehl um ein & am Ende erweitern, damit ich weiter auf der Konsole arbeiten kann. Das ist erstmal nicht so schlimm. Ich möchte beim starten des NAS den ProFTPd-Server auch mit starten. Aus diesem Grund vergebe ich ja auch die Rechte entsprechend wie du es oben beschrieben hast:

    chmod a+x /ffp/start/proftpd.sh

    Nun zu meinem Problem: Jetzt wird danach nix mehr gestartet. Somit wird beispielsweise der Webserver nicht mehr mit gestartet. Das konnte ich aus dem ffp.log entnehmen. Hast du vielleicht eine Lösung?

  5. Ich habe einen Zusatz für die Leute, die den ProFTPd-Server hinter einem NAS benutzen. Da der Datenteil auch verschlüsselt wird, muss die IP vom Router für das Außennetz verwendet werden. Dafür müssen noch zwei Parameter in der /ffp/etc/proftpd.conf gesetzt werden.

    MasqueradeAddress ftp.mydomain.com # DNS oder auch IP
    PassivePorts 60000 65535

    PassivePorts sorgt dafür, dass Dateiübertragungen im Passiv-Modus erfolgen können. Dafür muss im Router noch der entsprechende Bereich weitergeleitet werden. Ohne diese Einstellungen ging es bei mir nicht. Ich habe mein Wissen von hier.

      1. Hallo,
        ich habe einen std. ADSL Anschluss und bekomme ja täglich eine andere IP-Adresse…bla…

        Somit muss ich auch die „MasqueradeAddress“ bei proftpd jeden Tag ändern, aber leider klappt das nicht über den „crontab“ vom NAS.

        Bei der Verbindung scheitert er immer an den passiv Ports.

        Wenn ich jedoch den Dienst „proftpd“ manuell neustarte klappt es, Ideen ?

        crontab sieht so aus

        3 * * * * /ffp/bin/restart_ftp.sh

        In der restart_ftp.sh steht nur dass er den Server neustarten soll, wenn ich das script manuell aufrufe klappt es.

        Ideen ?

        Gruß und Vielen Dank

  6. Hallo Uli,

    doese Anleitung ist wirklich super. Aber jetzt hat sie einen Haken:
    es wird openssl-0.9.8h-1.tgz benötigt, das neueste fun_plug hat aber openssl-0.9.8j-1.tgz, womit die Sache nicht mehr läuft.
    Kannst Du eine neue proftpd mit Unterstützung das aktuellen openssl erstellen oder das openssl-0.9.8h-1.tgz als Download anbieten – ich finde es im Web nicht?

    Grüße
    vC

  7. Hallo Uli ich wollte mal fragen ob man die site Befehle in dem ProFTPd irgendwie aktivieren kann. Weil ich einene autotrader haben will der mir alle neuen Firmwares von meinen Geräten zieht aber dafür brauche ich den site exec Befehl. Über den Downloadplaner will ich das nicht machen weil der ja in einem bestimmten Intervall die Firmwares zieht … ich will ja aber nur die Neusten. Hast Du da eine idee?

    1. Normalerweise ist das unter FXP bekannt, wenn ich richtig liege. Das ist hier beschrieben.

      Im einfach:

      AllowForeignAddress on

      in der Config-Datei einfügen und los gehts, aber ich hab mich damit net wirklich auseinander gesetzt.

  8. Auszug auf dem SSHLog:

    Starting /ffp/sbin/proftpd --nodaemon --config /ffp/etc/proftpd.conf
    - warning: handling possibly truncated configuration data at line 49 of '/ffp/etc/proftpd.conf'
    DNS-323 - ProFTPD 1.3.2rc3 (devel) (built Sat Jan 3 11:15:04 CET 2009) standalone mode STARTUP
    DNS-323 (XXX.XXX.XXX[IP.IP.IP.IP]) - FTP session opened.
    DNS-323 (XXX.XXX.XXX[IP.IP.IP.IP]) - Preparing to chroot to directory '/usr/share/ftp_server'
    DNS-323 (XXX.XXX.XXX[IP.IP.IP.IP]) - USER Daniel: Login successful.
    root@DNS-323:/mnt/HD_a2/ffp/pkg# DNS-323 (XXX.XXX.XXX[IP.IP.IP.IP]) - ProFTPD terminating (signal 2)
    DNS-323 - ProFTPD terminating (signal 2)
    DNS-323 (XXX.XXX.XXX[IP.IP.IP.IP]) - FTP session closed.
    DNS-323 - ProFTPD 1.3.2rc3 standalone mode SHUTDOWN

    Warum schaltet der FTP sich automatisch ab, wenn nur 1 User drauf ist?
    Ich kann nur meiene Rootverzeichnis sehn aber nicht tiefer gehn.
    Der site-Befehl funst auch nicht

  9. So geupdatet ist alles. AllowForeignAddress on steh auch in der Config. Aber geht get trotzdem nicht. Hast du noch nen Tipp wo „AllowForeignAddress on“ stehn muss? Hab das jetzt mit stehn. Vorher hatte ich es einzeln mit in der Config aber da hat es auch nicht funktioniert.

  10. Hallo Uli,

    ich habs mal wieder mit ProFTPd versucht und natürlich auf anhieb Probleme bekommen.

    Ich habe leider auf dem NAS Ordner mit ä,ö oder ü im Namen.
    Sobalt ich mit FileZilla auf den Server zugreife,
    werden diese nicht korekt dargestellt.
    Diese Ordner können dann auch nicht geöffnet werden.
    Der Grund dafür ist das ich in der proftpd Konfig den Punkt: „AllowOverwrite“ auf off gestellt habe.
    Stelle ich diesen nun wieder auf on kann ich darauf zugreifen.
    Aber natürlich auch die Daten auf dem Server verändern.

    Ist es aber nicht auch möglich die Codierung zu ändern das diese Umalaute korrekt dargestellt werden?

    MfG

    Max

  11. Ach und noch eine Frage, habe gerade wieder auf den Standard FTP-Server zurück gestellt und bin über Mozilla auf den FTP.
    Dort wird der Ordner korrekt mit ü angezeigt nur sobalt ich diesen öffnen möchte geht das nicht.
    Da die Verlinkung das ü nicht übernehmen kann.

    Villeicht auch eine Idee ob das im Browser eine eigenen Einstellung ist?

    Zugriff über FileZilla funktioniert mit korrekter Darstellung und ohne Probleme beim Standard FTP Server.

    Gibt es beim ProFTPd eig. eine Drop Time?
    Habe vorhin nur gemerkt das ich wohl die falsche Verschlüsselung eingestellt hatte aber die richtigen Userdaten.
    Nur hatte ich mich dann wohl beim proftpd prozes angemeldet.
    Proftp ließ sich dann nicht restarten oder stoppen und erst ein „killall -9 proftpd“ Befehl hat ihn dann beenden können.

    MfG

    Max

  12. Hallo Uli,

    ich hab mal versucht, ProFTP auf dem NAS zum laufen zu bringen.
    Dafür wollte ProFTP die nogroup-Gruppe. Hab ich manuell über SSH angelegt. Aber nach einem Reboot war die Gruppe wieder weg und ProFTP konnte wieder nicht starten.
    Kannst Du mir evtl. sagen, warum das so ist bzw. was ich anders machen muss, damit die Änderung persistent bleibt?
    Danke und Gruß
    Andreas

    1. Na also dir als alter Hase sollte doch die store-passwd.sh was sagen 😉 Die danach aufrufen und zack is die Sache gelaufen 🙂

      PS: Die Gruppe wird während der Paketinstallation eigentlich angelegt, dazu wird eine Frage gestellt. War das nicht der Fall?

  13. Ich und alter Hase? Ha! Jetzt weiß ich ja nicht, ob ich rot werden oder mich schämen soll 🙂

    Die Gruppe für ProFTP wurde während der Installation angelegt, war aber nach einem Reboot weg. Manuell anlegen war kein Problem, aber die manuelle Änderung war nach einem Reboot wieder weg.

    Die store-passwd.sh sagt mir schon was, aber den Sinn dahinter umreiße ich erst jetzt ein bisschen.
    Ich hab nämlich noch diverse andere Probleme mit nicht-persistenten Änderungen an ffp-Dateien (genau wie die FTP-Gruppe), die alle nach einem Reboot wieder weg sind.

    Vielleicht wäre es hierzu möglich, dass Du mal einen Blick in diesen Thread werfen könntest

    Wenn die store-passwd.sh der Schlüssel für die Lösung meiner dort beschriebenen Probleme ist, dann wäre ich Dir über ein paar erläuternde Worte sehr verbunden.

    Herzlichen Dank im voraus.

    1. Na ich hab dich schon öfter nun in den Foren gesehen 😉

      Die store-passwd.sh speichert die Dateien:

      • /etc/passwd
      • /etc/group
      • /etc/shadow
      • /etc/samba/smbpasswd

      Auf den internen Flashspeicher, sodass diese nach einem Reboot wieder vorhanden sind.

  14. Ja gut, das mag sein – bei so nem geilen NAS (ich bin vollauf begeistert, das Teil macht richtig Laune) macht der „Community helfen“ Spaß.

    Danke für Deine Antwort im Forum. Hast Du noch ne Idee, wie ich mein SSH wieder korrigieren kann, denn im Moment hab ich mich ausgesperrt ?
    Gruß
    Andreas

  15. Just want to share this tips, because I lost 2 hours to find it :p

    If u want a link from the user’s home folder to an different folder
    U have to use the command
    mount -o bind /mnt/HD_a2/data/video /mnt/HD_a2/data/ftp/Uli/video

  16. Hallo Uli,

    zuerst einmal vielen Dank für deine Mühe – sowohl hier als auch in einschlägigen Foren. Dadurch hast du es einem Linux Noob wesentlich erleichtert und wohl in einigen Schritten erst möglich gemacht sein Nas (CH3MNAS) auszureitzen.
    Ich versuch mir zwar Fragen selbst durch anlesen anzueignen, auch nachzuvollziehen, was ich mit den jeweiligen Befehlen bewirke (n könnte), jedoch bin ich im moment mit meinem Latain am Ende.
    Ich habe nach deiner Anleitung Proftpd installiert, schaffe auch einen Zugriff von außen auf mein Nas, jedoch habe ich keine Chance, den Benutzer über „DefaultRoot“ in einem Verzeichnis einzusperren. Weder in seinem Home, noch was mir in meinem Fall lieber wäre einem festen anderen – sofern möglich.
    wäre toll wenn du mir einen tipp geben könntest – gern liefer ich auch noch mehr Infos.

    vg der b.

  17. Hey Uli ich haben folgende Idee und wollte dich fragen ob und wie ich die realisiern kann.

    Das Problem:
    ständiges entpacken von Rar-Dateien.

    Die Idee:
    Ich bekommen von mehreren Leuten Daten für unser Projekt. Alles als Rar’S. Und es nervt mich die immer zu entpacken und einzusortieren bzw dann beim entpacken zu merken, dass die Archive noch nicht fertig sind. Deswegen hab ich meine Zuspieler gebeten eine sfv-Datei zu erstellen damit ich checken kann ob die Archive richtig übertragen wurden. Jedoch muss ich das auch wieder manuell machen. Jetzt hatte ich die Idee warum soll das nicht automatisch gehn, dass auf Vollstänfigkeit geprüft und dann entpackt wird und dann die Archive loeschen. Falls ein Archiv beschädigt sein sollte soll der Dateiname in ein Log kommen.

    Denkst du das ist realisierbar?

    1. Warum nicht? Schreib dir doch nen Cron-Job, der die Files samt *.sfv prüft, diese bei Übereinstimmung entpackt und anschließend die Archive löscht. Wüsste nicht wo das problem ist 😉

      Viele Grüße,
      Uli

  18. Hallo Uli,

    erst einmal vielen Dank für Deine super Seite.

    Die Einrichtung des proftpd lief problemlos. Die Zugriffskonfiguration ist auch fertig, jetzt habe ich allerdings das Problem, das die aktuelle proftpd-Version keine LocalCharset und RemoteCharset Optionen besitzt. D.h. aus nem „Hörbuch“ im NAS-Verzeichnisnamen wird auf dem WindowsFTPClient ein „Hörbuch“.

    Hast Du eine Idee was man tun kann?

    Vielen Dank im Voraus.
    Grüße
    Tom

  19. Hi Uli,
    erstmal vielen Dank für deine Tutorials, die haben mich die letzte Stunde schön beschäftigt und es läuft alles wie es soll. Ich hab nicht grade viel Linux Kenntnisse, aber mit deiner Hilfe und meinem Halbwissen hab ich alles super hinbekommen.
    Abgesehen von einem jedenfalls:

    Status: Verbindung hergestellt, warte auf Willkommensnachricht…
    Antwort: 220———- Welcome to Pure-FTPd [TLS] ———-
    (…..)
    Status: Empfange Verzeichnisinhalt…
    Befehl: PWD
    Antwort: 257 „/“ is your current location
    Befehl: TYPE I
    Antwort: 200 TYPE is now 8-bit binary
    Befehl: PORT [lokale IP],252,215
    Antwort: 500 I won’t open a connection to [lokale IP] (only to [externe IP])
    Fehler: Verzeichnisinhalt konnte nicht empfangen werden

    Ich versuche im Moment von meinem lokalen Rechner auf die DynDNS Adresse meiner CH3MNAS zu verbinden, sprich mich von extern wieder in mein eigenes Netz einzuwählen. Ist allein das schon der Fehler? Mein Router hat die Ports 20/21 als Forward auf die Nas eingetragen, dazu auch 989/990 ohne Ergebnis und das was mir Filezilla in der Port Angabe vorschlägt (ändert sich kurioserweise ständig). Übrigens alles im Aktiv Modus, Passiv gibt zurück:

    Antwort: 227 Entering Passive Mode (192,168,0,105,136,85)
    Status: Vom Server gesendete Adresse für den Passiv-Modus ist nicht routingfähig. Passiv-Modus fehlgeschlagen.

    Ich würde mal vermuten, dass der pure-ftp hier nicht vernünftig mit dem Router kommuniziert, bzw durch die Verschlüsselung das gar nicht erst kann.

    Die passenden Optionen habe ich in der Doku schon gefunden, aber leider keine Ahnung wo und wie man die aktiviert:

    – ‚-p :‘: Use only ports in the range to inclusive for passive-mode downloads. This is especially useful if the server is behind a firewall without FTP connection tracking. Use high ports (40000-50000 for instance), where no regular server should be listening.

    – ‚-P ‚: Force the specified IP address in reply to a PASV/EPSV/SPSV command. If the server is behind a masquerading (NAT) box that doesn’t properly handle stateful FTP masquerading, put the ip address of that box here. If you have a dynamic IP address, you can put the public host name of your gateway, that will be resolved every time a new client will connect.

  20. Ah vergiss den letzten Absatz, der stammt aus der Doku zum falschen FTPd!

    Die richtigen Eintragungen in der conf Datei sind:

    MasqueradeAddress http://ftp.mydomain.com # using a DNS name
    MasqueradeAddress 123.45.67.89 # using an IP address

    PassivePorts 60000 65535 # These ports should be safe…

    Aber jetzt habe ich dafür ein neues Problem: Ich kriege immer die Meldung „falsches Passwort“ zurück, egal ob bei bestehenden oder neuen Usern und egal ob diese Mitglied in der „nogroup“ sind oder nicht.

    1. Ich habe die Box jetzt einmal komplett neu aufgesetzt, zuerst aktuelle Firmware rein und dann mit leeren Werkseinstellungen das fun plug nochmal neu installiert, das Ergebnis bleibt leider dasselbe. Und egal ob der originale oder proFTPd läuft, ich kriege keinen Zugriff mehr via FTP 🙁

      1. Würde mich wundern, wenn weder über den originalen noch über den proFTP noch eine Verbindung geht, wenn du die Box komplett resettet hast. Versuche mal die Box zu resetten, kein fun_plug zu installieren und schau mal ob FTP dann geht?

        1. Ohne fun plug hat es wunderbar funktioniert. Und solange ich den proFTP nicht installiert hatte ging es auch noch mit funplug und dem originalen FTP Server. Erst wenn ich den installiere geht nichts mehr. Habe auch schon die passwd kontrolliert, die User stehen an sich korrekt drin. Auch mit neuen Gruppen Zuweisungen konnte ich nichts erreichen. Das Problem ist allerdings reproduzierbar, bin mittlerweile bei Versuch 3 und langsam gehen mir die Ideen aus.

  21. Hallo Uli,
    ich hoffe, dass Du mir helfen kannst. Ich hab ein DNS 323 und ein DNS
    343 auf beiden läuft ProFTPD 1.3.2e aber auf beide NAS komme ich
    nicht mehr auf den FTP-Server mit der Begründung das das Passwort falsch
    wäre jedoch wenn der hauseigene FTP-Server läuft komme ich drauf. Jedoch
    brauche ich den Proftpd weil ich passive Ports einstellen muss. Hast du
    ne Idee wo ran das liegen kann?

    Was ich schon versucht habe.
    downgrade auf 1.3.2a –> funktioniert auf dem dns323 aber nicht auf dem dns343

  22. Hallo Uli, ich habe auf einem Suse-Server WING-FTP laufen, ist sehr komfortabel, da Benutzer und alles über Web konfiguriert werden kann. Wäre so eine Software auf dem CH3SNAS lauffähig?

  23. Ich habe ein Verständnis Problem(Linux-Newbie):
    Ich würde gerne bevor ich die Anleitung für den ProFTP durchgehe den internen FTPServer abschalten. Nur wie. Im Webinterface gibts keine Option dafür, oder bin ich blind?
    CH3SNAS FW 1.05

  24. Super Anleitung hat bis jetzt alles geklppt. E
    ine Frage wie bekomme ich Zugriff auf die DAtei proftpd.conf. Ich will die Kommentare entfernen.

    1. So ich habe es hinbekommen. Was aber nicht funktioniert:
      FTp des DNS323 hab ich gestoppt, bekomme auch einen Zugriff über proFTpd auf das NAS, aber ich bekomme einen L] 530 Login incorrect.

      Woran kann das liegen? Habe schon google bemüht, aber ich bekomme keinen Lösungsanatz. Vlt kann hier jemand helfen.

  25. Hi Uli,

    erst einmal vielen Dank für Deine vielen sehr hilfreichen Tutorials. Ich scheitere momentan daran, die Kommentare in der Datei /ffp/etc/proftpd.conf zu entfernen …
    d.h. die Datei lässt sich nicht speichern, da sie offenbar in Verwendung ist. proftpd habe ich aber gestoppt. Wo sitzt da bei mir der Denkfehler?

    Danke und Grüße

    Markus

      1. Hi Uli,

        vielen Dank für den Hinweis. MIt dem nano komme ich nun prima zurecht. Nun stehe ich aber vor einem weiteren Problem. Ich denke es ist ähnlich gelagert wie bereits der Beitrag hier von Max vom 01.01.2009.
        Die Gruppe „nogroup“ wurde angelegt. Allerdings erhalte ich jeweils die Meldung „login incorrect“. Starte ich den integrierten FTP Server, funktioniert es mit dem hinterlegten Nutzer und Passwort. Auch habe ich ebenfalls keine Datei „passwd“ im Verz. „etc“. Bereits versucht habe ich, den jeweiligen Nutzer der Gruppe „nogroup“ hinzuzufügen. Beide Varianten führen mich leider nicht zum Erfolg.
        Kannst Du mir hier evtl. auch noch einmal ein wenig auf die Sprünge helfen?

        Herzlichsten Dank vorab!

        Markus

  26. Hi Uli!

    Also auch mal von mir herzlichen Dank für deine Arbeit. Heute hatte ich endlich Zeit, sftp auf meinem DNS-320 zu aktivieren.

    Soweit, sogut, bis zum Connect zum Server funktionierte alles soweit. Nun bekomm ich allerdings immer die Meldung:

    ssh_init: Host does not exist
    Could not connect server

    Ich bin derzeit noch im internen Netz, mein NAS hat fixe IP auf 192.168.1.14 und proftpd läuft auf Port 1422. Ich komme auch am NAS an (die 105er bin ich über Filezilla):
    # cat /var/log/syslog | grep proftpd
    Jan 30 22:58:00 NAS proftpd[4004]: NAS – ProFTPD 1.3.3f (maint) (built Wed Nov 2 2011 18:59:20 UTC) standalone mode STARTUP
    Jan 30 22:58:10 NAS proftpd[4006]: NAS (192.168.1.105[192.168.1.105]) – FTP session opened.
    Jan 30 22:58:21 NAS proftpd[4006]: NAS (192.168.1.105[192.168.1.105]) – FTP session closed.

    Habs sogar schon von außerhalb probiert und auch das funktioniert soweit, aber bleiben wir erstmals im internen Netz.

    Firewall hab ich deaktiviert, auf dem NAS sollte meiner Meinung nach keine laufen. Beim Erstellen des SSL-Zertifikats laut deiner Anleitung bekam ich keine Fragen. Der „openssl req -new…“ ging so durch. Kanns vielleicht daran liegen?

    Würde mich über deine Unterstützung freuen.

    liegrü,
    Ralph

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.