RAID-Status des Conceptronic CH3SNAS wechselt nicht von DEGRADED nach RESYNC nach einem Reboot

In seltenen Fällen kann es passieren, dass das RAID1 auf dem Conceptronic CH3SNAS in den Status „DEGRADED“ wechselt. Das bedeutet, dass die beiden Festplatten nicht mehr auf dem gleichen Status sind. Um dies zu behebn reicht es im Regelfall einfach einmal neu zu starten, das NAS erkennt dann das Problem und wechselt in den Status „RESYNC„, in welchen dann die Festplatten wieder auf den gleichen Stand gebracht werden.
Manchmal klappt jedoch dieser Wechsel auf „RESYNC“ auch nach mehrmaligem Reboot nicht. Doch natürlich ist alles rettbar 😉

Werbung


Zuerst muss man das fun_plug installieren. Nach dem Einloggen per SSH oder Telnet muss man zunächst den Status des RAIDs ansehen:

# cat /proc/mdstat

Im Regelfall erhält man nun eine Ausgabe wie folgt:

Personalities : [linear] [raid0] [raid1]
md0 : active raid1 sda2[0] sdb2[1]
xxxxx blocks [2/2] [UU]

Wenn das RAID im „DEGRADED„-Status ist, dann steht in der letzten Zeile jedoch [_U] oder [U_]

Eine der beiden Festplatten fehlt also im RAID-Array. Welche das Ist, lässt sich mittels:

mdadm -D /dev/md0

herausfinden. Entweder /dev/sda2 oder /dev/sdb2 fehlt. Die fehlende Festplatte muss nun wieder ins Array hinzugefügt werden, was ich anhand der /dev/sda2 kurz demonstriere:

mdadm /dev/md0 -a /dev/sda2

was zur Ausgabe von „mdadm: hot added /dev/sda2“ führen sollte.

Im Webinterface oder mittels „cat /proc/mdstat“ kann man nun sehen, dass das Array wieder gesynct wird.

Kleine Anmerkung: In Firmware 1.04 wird es genau für dieses Problem eine Lösung geben. Ich vermute, dass man dann den Befehl, die Festplatte wieder hinzuzufügen manuell auslösen kann.

Quelle der Problemlösung

Veröffentlicht von

Uli

IT-Nerd und Admin

10 Gedanken zu „RAID-Status des Conceptronic CH3SNAS wechselt nicht von DEGRADED nach RESYNC nach einem Reboot“

  1. Latest firmware release of CH3SNAS has a new button in the setup/status screen of the GUI of the CH3NSAS
    So if it’s degrated and not automatcially solved you can manually do so without the need of fun_plug and above comments

    Tjsak!
    Dennis

  2. Hello Dennis,
    i wrote this article as a translation of your Walk-Trough. In the last part („Kleine Anmerkung:“) i wrote about Firmware 1.04, which will solve this issue 🙂 Probably many of the readers are too lazy to upgrade their Firmware, so with Firmware-version <1.04 you need this tutorial or are at least encouraged to upgrade.

    As soon as Firmware 1.04 is out, i will place that hint at the top of this article!
    Thanks for you comment!
    Greetz
    Uli

  3. Bei meinem CH3SNAS war das RAID1 plötzlich im Status „Degraded“. Nach einem Neustart des NAS Status „Resync“. Super eigentlich – nur hört der CH3SNAS nicht mehr auf zu resyncen. Sobald der Resync bei 100% ist fängt dieser wieder neu an. Zugriffe auf das NAS sollten eigentlich keine erfolgen: „lsof /mnt/HD_a2“ zeigt keine Ausgabe.

    Ist dieses Problem bekannt? Die Hotline sagt „RAID neu einrichten“. Problem ist nur das ich zur Zeit keine HDs habe um die Daten zu sichern.

    1. Hallo Thomas,
      hast du fun_plug drauf (ich gehe mal davon aus, wenn du lsof eingeben kannst)? Wenn ja, dann zeig doch mal die Ausgabe von

      cat /proc/mdstat

      Evtl. ist ja auch wirklich eine der Platten kaputt oder so.

  4. Ja, Funplug ist auf dem USB-Stick installiert.

    Ausgabe von cat /proc/mdstat:
    Personalities : [linear] [raid0] [raid1]
    md0 : active raid1 sdb2[1] sda2[2]
    730860992 blocks [2/1] [_U]
    [=>……………….] recovery = 5.0% (36852032/730860992) finish=140.0min speed=82580K/sec
    unused devices:

  5. Also so wie es aussieht ist das CH3SNAS wirklich kaputt. Es ist nicht mal mehr möglich Einstellungen (Zeitzone, Benutzer,…) zu ändern. Nach jedem Neustart sind diese Einstellungen wieder verschwunden. Zudem ist das NAS zeitweise nicht erreichbar. In diesem Zustand blinken die HD-LEDs und Nichts geht mehr (auch nicht der Ausschalter). Nur noch Strom abziehen hilft.

  6. Hallo,

    bei mir hatte ich den Fall mit dem dem Status “DEGRADED”. Ich bin auf die Weboberfläche und die Platten wieder synchronisiert. Jetzt habe ich aber das Problem, dass bei jeder Neuanmeldung der Raid Wizard erscheint, obwohl wieder alles ok ist.

    Ich habe aber trotzdem etwas Bauschmerzen, kann man nicht den Smart-Status auslesen oder per Mail versenden, wenn Probleme erkannt werden?

    1. Mailbenachrichtigung sollte es eigentlich geben, dafür gibt es (soweit ichs grad im Kopf habe) doch einen Punkt in den Alert-Einstellungen?

      SMART kannst du meines wissens auslesen, wenn du smartmontools installierst, welche es bei fonz zum Download gibt. Wenn du den Status des RAID prüfen willst, steht ja oben wie es geht 😉

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.